Cannot login to Microsoft Whiteboard? Read how to fix error CAA20002

I’ve encountered an issue where Microsoft Whiteboard showed me the error code CAA20002. I did the usual troubleshooting, I tried to repair, reset, and to re-install the app but it didn’t help, every time I got the same error when I tried to log in.

I tried to open the Whiteboard app on a different computer, using the same account and it worked just fine, so I compared Whiteboard versions between the two computers and they were different. Whiteboard didn’t want to auto-update on the affected computer, even though I left it turned on for almost 2 days (yes, it had Internet connectivity 😊). I thought that the Microsoft Business Store would have the most current offline version of the Whiteboard app and I hoped that installing the offline version will cure it. Surprisingly, the Business Store had the same version that wasn’t working for me, which led me to search for a possible solution, and as usual, Reddit didn’t disappoint.

This Reddit post nailed it, it describes “How to download Windows Apps without Microsoft Store“, thanks to that post I was able to download the newest version of the Whiteboard offline installer.

How to fix your Whiteboard app

So to cure my Whiteboard app, I did the below steps:

  • from the long list of files, I downloaded:
    • “Microsoft.Whiteboard_<version number>_neutral_~_8wekyb3d8bbwe.appxbundle”
    • dependencies (you can check the current list of dependencies in the MS Business Store):
      1. Microsoft.NET.Native.Framework.<version number>_x64__8wekyb3d8bbwe.Appx
      2. Microsoft.NET.Native.Runtime.<version number>_x64__8wekyb3d8bbwe.Appx
      3. Microsoft.VCLibs.<version number>_x64__8wekyb3d8bbwe.Appx
  • Afterward, I removed the current Whiteboard application – I did it via a PowerShell script as I’ve seen that the older versions of the App were created with .appx extension and the newer ones are with appxbundle and because of this, there is a different way to uninstall the application. Below is the script I used to uninstall Whiteboard:
if ((Get-ChildItem "HKLM:\SOFTWARE\Microsoft\Windows\CurrentVersion\Appx\AppxAllUserStore\Applications*Whiteboard") -like "neutral") {
    Get-AppxPackage -AllUsers -PackageTypeFilter Bundle -Name "Whiteboard" | Remove-AppxPackage -AllUsers 
elseif ($null -eq(Get-AppxPackage -Name "Whiteboard" -AllUsers -ErrorAction SilentlyContinue).Version) {
    Get-AppxPackage -AllUsers -Name "Whiteboard*" | Remove-AppxPackage -AllUsers 
  • Now it’s time for installing the freshly downloaded Whiteboard with its dependencies, to make it simple you can place all files in one directory, for instance, “C:\Install\Whiteboard” and you can create a CMD file (for example install.cmd) to launch the installation (please modify the file versions as they will change in time). In the Install.cmd paste the below code:
Dism.exe /Online /Add-ProvisionedAppxPackage /PackagePath:"%~dp0Microsoft.Whiteboard_52.10801.429.0_neutral___8wekyb3d8bbwe.AppxBundle" /DependencyPackagePath:"%~dp0dependencies\Microsoft.NET.Native.Framework.2.2_2.2.29512.0_x64__8wekyb3d8bbwe.Appx" /DependencyPackagePath:"%~dp0dependencies\Microsoft.NET.Native.Runtime.2.2_2.2.28604.0_x64__8wekyb3d8bbwe.Appx" /DependencyPackagePath:"%~dp0dependencies\Microsoft.VCLibs.140.00_14.0.30704.0_x64__8wekyb3d8bbwe.Appx" /Region:"All" /SkipLicense
  • Open CMD as administrator and run the Install.cmd file
  • Your Whiteboard app should now let you log in

I hope that this post will help you with your Whiteboard issues and possibly with other Microsoft Store application issues, for which the well-described troubleshooting steps do not resolve the problem.

Leave a Comment

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.

Scroll to Top